Click here to visit our UK based sponsor store €urosky....... Click here to visit our Ireland based sponsor store @ Sat-TV-help.......

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Faulty PSU

      
   
  1. #11
    Junior Member msawad's Avatar

    Join Date
    Jan 2014
    Posts
    26
    Quote Originally Posted by unknown View Post
    I think its the front panel at fault could I connect that to any other box to see if it powers up?
    cannot do that , Do you have black tv screen? if yes it is mostly PSU or flash memory need reprogrammed
    Truman Top Box 2 tuner (same as Amiko Alien 2)
    240cm Motorized Dish

  2. #12
    Donated member unknown's Avatar

    Join Date
    Mar 2012
    Posts
    245
    Thread Starter
    Quote Originally Posted by msawad View Post
    cannot do that , Do you have black tv screen? if yes it is mostly PSU or flash memory need reprogrammed
    Everything is 100% working except the buttons on the box and the VFD. I can change channels using smartphone
    Amiko Alien2 (Triple Tuner) | TM TWIN OE (OpenViX 3.0.343) | VU+ DUO (OpenViX 3.0.343) | TM800HD (DWiQ 16/07/11) | TM500Super (iQ 31/08/2011)

  3. #13
    Junior Member msawad's Avatar

    Join Date
    Jan 2014
    Posts
    26
    in such a case , your STB PSU is 100% ok
    The problem located in the front panel IC or in the ribbon cable. The wiring diagram is needed for diagnosis.
    Just try physical check for a blown resistor on the front panel board or near the ribbon end on the mainboard
    Truman Top Box 2 tuner (same as Amiko Alien 2)
    240cm Motorized Dish

  4. #14
    Donated member unknown's Avatar

    Join Date
    Mar 2012
    Posts
    245
    Thread Starter
    Don't think its the ribbon as that just controls the display not the actual buttons I think, I removed the ribbon and put back securely nothing happens. Don't know nothing about resistors etc.
    Amiko Alien2 (Triple Tuner) | TM TWIN OE (OpenViX 3.0.343) | VU+ DUO (OpenViX 3.0.343) | TM800HD (DWiQ 16/07/11) | TM500Super (iQ 31/08/2011)

  5. #15
    Donated member unknown's Avatar

    Join Date
    Mar 2012
    Posts
    245
    Thread Starter
    Really weird but everything is working again, for how long I don't know. Earlier on I noticed the VFD had red light that kept coming on and off and finally the channel name appeared. Remote started working and then about 20minutes later it went dead again. Left it for an hour and is now on and working. God know what caused it.
    Amiko Alien2 (Triple Tuner) | TM TWIN OE (OpenViX 3.0.343) | VU+ DUO (OpenViX 3.0.343) | TM800HD (DWiQ 16/07/11) | TM500Super (iQ 31/08/2011)

  6. #16
    TM fanboy :) digidude's Avatar

    Join Date
    Mar 2012
    Location
    De Cymru
    Posts
    3,076
    Casino Cash
    £334041
    this may sound wierd, but, ive seen similar to this before, where something would only work if the heating in the house was on quite high.

    It was a loose ribbon cable, and where everything warmed up, copper expands, and was making the connection, if the heating wasnt on, then it wouldnt work, so these people were watching telly with the heating on full blast, cos once the room cooled down enough, things started playing up again

    try the end of the cable on the front panel itself m8, completley remove it and push it back in, just to make sure everything is seated properly


    Viewing as a guest? Click HERE to register and see the good stuff

    I break my stuff, so you wont have to

    If this post offends you, dont read it.

    Allergy Warning! Posted by a nut

    My OTHER hobby, im not all satellite releated fun
    Technomate blog

    Click here to order direct from €urosky


    Quote Originally Posted by A-joker
    Some people read far too much crap on other forums from so called experts who them selves know sweet FA

  7. #17
    Donated member unknown's Avatar

    Join Date
    Mar 2012
    Posts
    245
    Thread Starter
    Iv done that, and thinking about it makes sense has the boiler pump went last week and took British gas 6 days to replace it so we had no eating other than some electric fan heaters which we had to keep moving. Not the sort of thing you would expect to affect a STB though. BTW Happy New Year DD its been awhile hope your good
    Amiko Alien2 (Triple Tuner) | TM TWIN OE (OpenViX 3.0.343) | VU+ DUO (OpenViX 3.0.343) | TM800HD (DWiQ 16/07/11) | TM500Super (iQ 31/08/2011)

  8. #18
    Junior Member msawad's Avatar

    Join Date
    Jan 2014
    Posts
    26
    Quote Originally Posted by unknown View Post
    Really weird but everything is working again, for how long I don't know. Earlier on I noticed the VFD had red light that kept coming on and off and finally the channel name appeared. Remote started working and then about 20minutes later it went dead again. Left it for an hour and is now on and working. God know what caused it.
    the symptom you stated give a big doubt in the front panel IC (it is a regtangular black piece with many legs) .
    when the IC get hot nothing is working.
    There is a test for that problem by freezing the IC using a special spray Can ( called CO - Cooler) but sure you dont have in home.

    Try the below steps if you can:

    1- Keep the STB cover removed
    2- locate the IC in the front panel (usually front panel have only ONE IC chip)
    3- keep the STB ON all time
    4- when the problem happen spray the IC by a perfume spray or eau de toilet spray (because you dont have CO - Cooler spray) . The Alcohol with evaporate and cool down the IC and its internal parts shrink
    5- if the front panel back to work again that means the IC is 100% failure
    Truman Top Box 2 tuner (same as Amiko Alien 2)
    240cm Motorized Dish

  9. #19
    Member CG121's Avatar

    Join Date
    Apr 2012
    Posts
    140
    This is my last post on this as the fault has been seen before and identified as the 5v regulator on the PSU PCB.

    You can fcuk about with ribbon cables and freezer spray if you like but it won't fix it..

    As I said to TM, more twins will exhibit this problem as the PSU design isn't too great..

    Here's some images of the damage causing your problem..

    IMG_0006.jpg
    IMG_0004.jpg

  10. #20
    TM fanboy :) digidude's Avatar

    Join Date
    Mar 2012
    Location
    De Cymru
    Posts
    3,076
    Casino Cash
    £334041
    Quote Originally Posted by CG121 View Post
    This is my last post on this as the fault has been seen before and identified as the 5v regulator on the PSU PCB.

    You can fcuk about with ribbon cables and freezer spray if you like but it won't fix it..

    As I said to TM, more twins will exhibit this problem as the PSU design isn't too great..

    Here's some images of the damage causing your problem..

    IMG_0006.jpg
    IMG_0004.jpg
    thats a bit of a shitty reply, when the only other reply to this thread points to another forum, where only one post is visable (i looked and can only view the first post)

    after looking at your pics, and at the pic unknown posted, you could have easily pointed out the discolouring around the regulator IC, these are nearly as common to fail in PSUs as caps are, and are less than £1.50

    http://www.ebay.co.uk/itm/VIPER22A-V...item1e801ef0ba

    if you look for the same chip used in a sky+ box, youll see they are better sellers, as they fail more often, and even actually explode in the case of amstrad receivers


    Viewing as a guest? Click HERE to register and see the good stuff

    I break my stuff, so you wont have to

    If this post offends you, dont read it.

    Allergy Warning! Posted by a nut

    My OTHER hobby, im not all satellite releated fun
    Technomate blog

    Click here to order direct from €urosky


    Quote Originally Posted by A-joker
    Some people read far too much crap on other forums from so called experts who them selves know sweet FA

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Webutation

Flag Counter
TopSat.Org The Best Satellite Top Lists !!! Daily Stats !!!